Ubuntuのアップデートエラー

最近、Lubuntuのアップデートを行うと以下のようなメッセージが表示されるようになりました。

  • このようなリポジトリから更新を安全に行うことができないので、デフォルトでは更新が無効になっています。

詳細なメッセージを見てみると、launchpadから追加したlibreoffice関連パッケージがエラーを引き起こしている模様。
(そういえば、LibreOfficeを導入する際にPPAを入れたんでした)。

当該のsources.listを修正します。
$ /etc/apt/sources.list.d/libreoffice-ubuntu-ppa-xenial.list

変更前
# deb-src http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial main
deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial main
変更後
# deb-src http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial main
# deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial main

修正後、再度アップデートを行うと、正常に終了しました。

$ sudo apt update
アップグレードできるパッケージが 10 個あります。表示するには 'apt list --upgradable' を実行してください。
$ sudo apt upgrade
アップグレード: 10 個、新規インストール: 0 個、削除: 0 個、保留: 0 個。
1,896 kB のアーカイブを取得する必要があります。

併せて、"apt autoremove"も実行しておくと良いかもしれません。